PDA

View Full Version : CSS problems with one of my themes



maroso2602
10-16-2012, 10:11 PM
Plugin is working great with profits theme but when I use headway theme the name, email and subscribe fields doesn't show correctly, they show outside the popup/box. The subscription process goes fine.

I've tested it on a demo wordpress install only with headway theme and wpsubscribers plugin and have the same problems.

Thanks for help

maroso2602
10-18-2012, 07:40 AM
Forgot to mention, that the optin popup shows fine in preview mode.

I've tried this to (from here: http://forum.obviousidea.com/threads/570-More-Form-Documentation-Post-Forms )

To have email and name in the same line: .wpsform br { display: none;}

to center the optin form: #ia-optin-form {margin: 0 auto;}
But it doesn't work

Any sugestion?

Jean-Christophe Bisoux
10-18-2012, 08:59 AM
Hi,
do you have a live exemple ? It will be easier to find the good CSS for your theme

Regards,

maroso2602
10-18-2012, 04:02 PM
I've solved the problem with in post opt-in form. I've added this into the custom css box:
.ia_form form input {display: inline;}

It's displaying fine now

It's running fine now for post opt-ins, but I can't figure out how to solve the opt-in popup. Live example is here: http://iguanacareguide.org/testblog/
and the Header Opt-in Form & Footer Opt-in Form. Live example is here: http://iguanacareguide.org/testblog/test-post-2-header/

Any suggestions?
Thanks

Jean-Christophe Bisoux
10-20-2012, 07:14 AM
Hi,
It's a issue from your theme, for exemple if you delete in the template CSS (general-b936011.css) this part of code



input[type=text],input[type=password],input[type=email],textarea,select {
border: 1px solid #ccc;
padding: 6px 4px;
outline: none;
-moz-border-radius: 2px;
-webkit-border-radius: 2px;
border-radius: 2px;
color: #777;
display: block;
background: #fff;
box-sizing: border-box;
-moz-box-sizing: border-box;
}


the popup appear fine

Regards,

maroso2602
10-20-2012, 01:39 PM
Thanks, but where can I find the "general-b936011.css" file? I've searched in the template folder but didn't find it.

Jean-Christophe Bisoux
10-20-2012, 05:26 PM
If you see in your code, you have this adress:

http://iguanacareguide.org/testblog/wp-content/uploads/headway/cache/general-b936011.css?ver=3.4.2

But It seem it's with a cache system

maroso2602
10-21-2012, 04:38 AM
Problem solved. Thanks...:)

Update: Every time I'm working in the headway's visual editor somehow headway clears the cache and rewrites the general-b936011.css file ( http://iguanacareguide.org/testblog/wp-content/uploads/headway/cache/general-b936011.css?ver=3.4.2 ) to the original version...

Any other suggestion?

Jean-Christophe Bisoux
10-21-2012, 06:02 AM
Hi,
I don't know how is working your theme, is beter to ask directly to the editor theme
Regards,

flogger123
10-21-2012, 04:28 PM
This reallt garbled my head and I got nothing on top of it. Have you tried creating a support ticket yet? https://imagicon.info/cat/13-48/vbbiggrin.png