PDA

View Full Version : Opt-In Pop-up always shows



michaelrichardmurphy
02-14-2013, 07:59 PM
I'd like my opt-in pop-up to appear once every four days when visitors first visit the homepage. SO, I have the following settings:

In the Opt-In pop settings themselves, I have only the homepage enabled. In the Time settings, the Opt-In form is set to show 1 times in 4 days, and after 0 page views.

Is this incorrect? Currently the pop-up shows only on the homepage (this part is correct) but it shows *every* time someone visits the homepage.

Either I am using the wrong settings or the cookies aren't working properly. Any suggestions?

-MRM

Jean-Christophe Bisoux
02-15-2013, 05:08 AM
Hi,
I think more about an issue with the cookies, can you send me the url ?

regards,

michaelrichardmurphy
02-15-2013, 02:37 PM
Hi,
I think more about an issue with the cookies, can you send me the url ?

regards,

Thank you for your quick response. The URL is http://usgolftv.com/

The pop-up should only pop-up on the homepage once every four days. So I think I should have accomplished that with the settings I mentioned above.

-MRM

michaelrichardmurphy
02-15-2013, 02:38 PM
Hi,
I think more about an issue with the cookies, can you send me the url ?

regards,

Thank you for your quick response. The URL is http://usgolftv.com/

The pop-up should only pop-up on the homepage once every four days. So I think I should have accomplished that with the settings I mentioned above.

-MRM

Jean-Christophe Bisoux
02-15-2013, 03:20 PM
I have the same problem, can you send me (by direct message) a temporary admin account to check in your admin the config ?

Jean-Christophe Bisoux
02-15-2013, 05:03 PM
Do you have a cache system on your hosting ?
there is something strange if I desactive the WPS plugin it continue to appear

michaelrichardmurphy
02-15-2013, 06:16 PM
They do have a caching option but I disabled it a few days ago for the purpose of testing/debugging this plugin.

Jean-Christophe Bisoux
02-16-2013, 05:41 AM
Can you try this test :

- go to http://usgolftv.com, wait the page is loaded with the popup.
- open another tab and go to the WPS admin in Optin pop up disable the option
- return to http://usgolftv.com and reload the page

do you see the popup ? (for me yes and the popup was desactived)

michaelrichardmurphy
02-16-2013, 11:39 AM
That is interesting.

For we when I reproduced your test, I did not get the popup again.

But I did get it when I visited another page on the site and came back to the homepage.

So it looked to you like the cookies are being created properly but for some reason they aren't work?

-MRM

Jean-Christophe Bisoux
02-16-2013, 01:11 PM
I think the cookie are create but after it's like a cache version and the cookie are not updated (I see on the debuger the value didn't change)And the same problem if I activate the plugin I didn't see the popup and the source didn't have the WPS plugin.
Your hosting didn't have cache system ?

michaelrichardmurphy
02-16-2013, 03:48 PM
They do offer caching. But I have disabled it so I'm not sure what's going on. Perhaps I will have to come up with a different solution :( Thank you for all your help though. I do appreciate it.

michaelrichardmurphy
02-21-2013, 06:55 PM
Hi Jean-Christophe,

I spoke to support at the hosting company. They can create exception rules for any files that need to read or write to the cookie. Is that all handled from javascript or are there PHP plugin files in the plugin that read/write also? If so, can you tell me which files they are?

Thank you,
MRM

Jean-Christophe Bisoux
02-22-2013, 05:59 AM
Hi Michael,

the physical file in WPS that create and read the cookie is wpusbscribers/output.php
but maybe the the exception must be the url where you use the popup from wordpress ?

Regards,