PDA

View Full Version : Upload not working



Arshad Hussain
03-03-2013, 04:01 PM
I used the program once and it worked great, but the image sizes were not at full resolution, so I set it to 2048 instead of 960, and when I went to upload my pics to facebook, it said it completed it, but there weren't any pics uploaded. Also the progress bar for each picture didn't advance at all like it did the first time I uploaded. So I tried uninstalling the program and re-installing it, but it looks like it remembered my settings from before (even after a reboot). Not sure how to fix this. Help! This program looks very promising though.

276

Phil
03-04-2013, 10:40 AM
To clear all settings, delete the config file in %appdata%\Obvious Idea\EasyPhotoUploader. Then try to see if it works again.

Arshad Hussain
03-05-2013, 06:29 AM
Hi Phil,
Thanks for your reply. I went ahead and deleted the config file and then later that whole directory, and while that did appear to clear the settings. It still didn't work with the uploads. I noticed that there was a log there, and I see some messages in the log that maybe of help in debugging this issue. Unfortunately the log file is 338k and is too big to attach here, so I'm attaching the end of the log message. It looks like this maybe the issue: error=Access violation at address 004F2BE7:

1 - Debug - TResizePicturesManager.import : begin
1 - Debug - TResizePicturesManager.import : Addes : 2 photo(s). Total Photos : 2
1 - Debug - TResizePicturesManager.scanAlbums : begin
1 - Debug - TResizePicturesManager.scanAlbums : Number of albums : 1
1 - Debug - TResizePicturesManager.scanAlbums : Retrieve Album: 10151436633043930
1 - Debug - TResizePicturesManager.scanAlbums : Photo in album 10151436633043930 - C:\Users\Arshad\Desktop\02-17-lunch\VP3A8649.JPG
1 - Debug - TResizePicturesManager.resizePhoto : begin
1 - Debug - TResizePicturesManager.resizePhoto : Analyzing the photo
1 - Debug - TResizePicturesManager.resizePhoto : Detect photo otientation
1 - Debug - TResizePicturesManager.resizePhoto : Rotate the photo
1 - Debug - TResizePicturesManager.resizePhoto : Resize the photo
1 - Debug - TResizePicturesManager.resizePhoto : max size : 2048
1 - Debug - TResizePicturesManager.resizePhoto : Need to resize
1 - Debug - TResizePicturesManager.resizePhoto : ratio : 0.38
1 - Error - TResizePicturesManager.resizePhoto : ERROR during conversion.class=EAccessViolation. error=Access violation at address 004F2BE7 in module 'EasyPhotoUploader.exe'. Read of address 00000000
1 - Debug - TResizePicturesManager.resizePhoto : end
1 - Debug - TFacebookManager.addPhoto : Begin
1 - Debug - TFacebookManager.addPhoto : End
1 - Debug - TResizePicturesManager.scanAlbums : Photo in album 10151436633043930 - C:\Users\Arshad\Desktop\02-17-lunch\VP3A8650.JPG
1 - Debug - TResizePicturesManager.resizePhoto : begin
1 - Debug - TResizePicturesManager.resizePhoto : Analyzing the photo
1 - Debug - TResizePicturesManager.resizePhoto : Detect photo otientation
1 - Debug - TResizePicturesManager.resizePhoto : Rotate the photo
1 - Debug - TResizePicturesManager.resizePhoto : Resize the photo
1 - Debug - TResizePicturesManager.resizePhoto : max size : 2048
1 - Debug - TResizePicturesManager.resizePhoto : Need to resize
1 - Debug - TResizePicturesManager.resizePhoto : ratio : 0.48
1 - Error - TResizePicturesManager.resizePhoto : ERROR during conversion.class=EAccessViolation. error=Access violation at address 004F2BE7 in module 'EasyPhotoUploader.exe'. Read of address 00000000
1 - Debug - TResizePicturesManager.resizePhoto : end
1 - Debug - TFacebookManager.addPhoto : Begin
1 - Debug - TFacebookManager.addPhoto : End

Phil
03-05-2013, 09:19 AM
Ok, it looks like something went wrong during resize. Can you send me one of those images, so I can check it?

If it's big, probably the best way is to upload on Minus (http://www.minus.com), and PM me the link.

Phil
03-06-2013, 12:36 PM
I fixed a bug with the interpolation setting.

Please try the new version:
http://download2.obviousidea.com/EasyPhotoUploader_for_Facebook_setup_2.0.4.5_linku lar.exe

Arshad Hussain
03-07-2013, 04:39 PM
Awesome! It actually uploads now and I can see images. Thanks Phil, it looks like you fixed it! :)