View Full Version : Server Threw An Exception

08-25-2013, 04:42 PM
I get an error when I right click on a photo file to resize. The error says "The Server Threw An Exception" and when I exit out of that it takes me to the regular program which I then have to select file(s) to resize. I've reinstalled the program and am using Windows 8 PRO. Can you help? I'd like to resolve this issue BEFORE I buy a PRO license.
Thank you

08-26-2013, 11:24 AM
Please follow these steps to resolve the problem:
- uninstall Light Image Resizer
- re-install with option "Add Light Image Resizer to Explorer context menu" disabled
- download and install this package: http://download2.obviousidea.com/hidden/lir_shellext.exe

This will add an alternative shell extension which shouldn't cause this error.

08-26-2013, 06:07 PM
Thank you for your reply and instructions. IT WORKED! It solved my issue. I bought my PRO license today and am pleased with how this product operates. Thanks again...

10-04-2014, 03:59 AM
I was wondering if there's a solution to this issue that doesn't require you to disable the Explorer context menu, that's a feature that's incredibly important to me for this software. Never had this issue before but on my new Lenovo laptop with Windows 8.1 I get this error and it's super annoying.

10-06-2014, 08:38 AM
If you read the full post you will notice that the steps mentioned above will not disable the context menu, but exchange it with an alternative one.

10-06-2014, 05:19 PM
Thanks for the response, Phil. I'm not sure I understand. How would I get Light Resizer to appear in the Explorer Context Menu if on install I uncheck the box to enable that feature? Is there a way post-install to re-enable that feature?

10-07-2014, 10:04 AM
Above I'm describing 3 steps. The last one installs the alternative shell extension for the context menu.

10-08-2014, 07:11 AM
It would seem I aim on being difficult. I'm on Windows 8.1 and this solution did not fix my problem. I did install without Context Menu and then installed the shell succesfully. Re-started but still getting same error. Any ideas?

10-09-2014, 10:08 AM
The new context menu entry should have a different icon than before... Did you uninstall Light Image Resizer before re-installing it without context menu integration?

10-14-2014, 07:17 AM
Hi Phil,

Figured it out! I did uninstall the first time and re-installed but it did not work. Here's what I did differently... Not sure what steps in the process are what resulted in success but it worked for me after I did the following:

- Uninstall Light Image Resizer
- Restart computer
- Navigate to Program Files folder, locate ObviousIdea folder. Delete it.
- Restart computer
- Re-install with option "Add Light Image Resizer to Explorer context menu" disabled
- Download and install this package: http://download2.obviousidea.com/hid...r_shellext.exe

I noticed that after I uninstalled (even when it asked me if I wanted to delete all logs and files) that it left an Obvious Idea folder in my Program Files. Once I uninstalled the program and deleted that folder it worked fine for me. And yes I do see the new icon for it.

Thanks again for your help!