PDA

View Full Version : 4.5.4 hanging for me.



rsilvers
11-04-2013, 04:26 PM
I really like how fast your resizer is - about 8x faster than any other I have found. So I really want it to work.

I am resizing about 14,000 photos from 380x160 to 190x80 pixels and it tends to hang at around 87% complete. Sometimes 92% complete with the same files. I have tried it with and without Kaspersky anti virus on.I tried Lazarus and linear. It does not hang at the same % complete each time or even the same file each time.

This happened with 4.5.3 and 4.5.4.

I am on Windows 8.1. I have a 10 core Xeon processor and 64 GB ram.

And that if that worked, the one other feature I would love is to be able to crop and then resize in one pass.

Phil
11-04-2013, 05:51 PM
Whew, that sure is a ton of photos! But it should work nevertheless...

First you can try the latest beta which fixes several problems, including some deadlocks:
http://download2.obviousidea.com/hidden/light_image_resizer4_setup_4.5.4.5.exe

If the same problem is still happening, the following information might be useful to investigate further:
1) When it hangs, can you still toggle the log by clicking "Details" or is it completely unresponsive?
2) It would be interesting to know the application's memory footprint once it hangs. Could you check with task manager?

rsilvers
11-04-2013, 06:39 PM
I can click on the Details and it opens and closes. Also a highlight continues to move through the green progress bar.

I see four threads in task manager, and each is reporting 5.1% CPU - so for some reason it is still using CPU but not advancing to the next photo. It says Estimated remaining time: 2 minutes.

Each thread is using about 24 MB.

I tried the Beta and it did not help.

In my log, there is a lot of: "2013-11-04 13:30:10 Info Log message threshold reached, message disabled"

Phil
11-05-2013, 09:21 AM
Ok, looks like I need to test with a huge bunch of images. The maximum I've tried so far was around 2000.

To be as close to your use case as possible:
What format are your source files (JPG, BMP, mixed, etc) and what's the output format?
Any other options used, like watermark?

Or, if you can send me the log that'd be even better: philipp (at) obviousidea (dot) com
Log files can be found in C:\Users\<USERNAME>\AppData\Roaming\ObviousIdea\

rsilvers
11-05-2013, 01:21 PM
Great. I sent you a google drive share link to the photos. There is no watermark.

Phil
11-06-2013, 12:06 PM
Using your files I was able to find and fix several issues.

Please try this new version and let me know if it works for you:
http://download2.obviousidea.com/hidden/light_image_resizer4_setup_4.5.4.8.exe

rsilvers
11-06-2013, 03:13 PM
Great. I am away for another 1-2 days, but will try it when I can. One thing I want to try is to replicate the collection into one with more than 100,000 photos and see if it can handle that. Maybe you should just try that since I can't do it today?

Also - it seems to limit itself to four threads. Would it be faster if it used more threads? I have a 20 thread machine and an SSD. Or is the bottleneck I/O?

Phil
11-06-2013, 07:42 PM
I found another issue which seems to be causing memory hog. Got to get rid of that first, before doing even more extensive tests.

Phil
11-07-2013, 06:05 PM
So, yet another version:
http://download2.obviousidea.com/hidden/light_image_resizer4_setup_4.5.4.9.exe

Here I've tried 40.000 images so far, which worked fine.

Btw, forgot to answer your question: It should detect the number of physical cores and use them accordingly. On my Core i7 for example it's using 8 threads.
The log should have a line like this: "Available threads: 8"

rsilvers
11-08-2013, 12:40 PM
That worked for me. Thank you.

The log file says that I have 20 threads available.

rsilvers
05-17-2014, 02:39 PM
So everything was working fine with me up until now. I have resized up to 160,000 files at a time, over and over with no problems. Each time I started up the app, I ignored the "new version update" notice as things were fine, I didn't think I needed an update, and I was afraid the update would break something in the middle of a critical project.

Well yesterday I finally updated to the latest version, and now I cannot get through resizing even 6000 images. It seems like the latest version broke the ability to resize a lot of files.

rsilvers
05-17-2014, 09:45 PM
I have confirmed that 4.5.8 can resize my files wheras 4.6.2 cannot.

Phil
05-20-2014, 02:32 PM
Thanks for reporting. I found some stability issues with large batches.

Please try again with the latest version:
http://download2.obviousidea.com/light_image_resizer4_setup.exe

So far it worked fine with 14.000 images.