View Full Version : command line /Mask not working in v4.7.2.0

08-03-2015, 01:18 PM
i have the latest version installed ( as of today 3-aug-2015) but when i'm running the program from the command line it was putting "(copy)" in the destination file name. even though i have the parameter "/Mask=%%F" in my batch file! btw double % is required otherwise the batch file will looks for a variable. I eventually got the problem solved by removing the parameter "/Run" but it should be working without me removing this.. i think a bug was introduced with v4.7.2.0 or perhaps earlier?

everything ok with the below params but if i add "/Run" the dest. file has "(copy)" in it!

any help here?

08-04-2015, 12:02 PM
As you have guessed, this seems to be a bug. I'll have it fixed for the next release!

08-12-2015, 07:37 AM
I've prepared a pre-release version with the fix. Could you test it and let me know if it works correctly for you?

light_image_resizer4_setup_4.7.2.2.exe (http://download2.obviousidea.com/hidden/light_image_resizer4_setup_4.7.2.2.exe)

08-25-2015, 06:28 PM
hi Phil,

thanks for reply. sorry for slow reply as i only just read your reply - i was not subscribed to the thread (default). i've subscribed now :)

i just installed the latest today. it fixed the file name mask problem when running the program from the command line but there is a new problem. i have "/W=500 /H=667" but the program runs as if i had used "/W=667 /H=667" so my images were resized to 667 pixels wide instead of a maximum of 500.. i tried your earlier version posted above (light_image_resizer4_setup_4.7.2.2.exe) and that problem does not exist in that version so i'll use that until you investigate the problem and release a new update.

one other problem i had with (when run from the command line) was that the unit setting was not defaulting to pixels as stated in the switches.txt file. i had to add "/Unit=pixel" to my batch file.


08-26-2015, 03:45 PM
I made some changes to the command line parsing, and apparently it switched the unit to percent.

Please try this version and let me know if it works correctly:
light_image_resizer4_setup_4.7.3.1.exe (http://download2.obviousidea.com/hidden/light_image_resizer4_setup_4.7.3.1.exe)

08-26-2015, 09:50 PM
works great :D i installed it over the and took out the "/Unit=pixel" from my batch file. also took out "/Mode=fit" as thats the default anyway.

i'm really impressed with the speed the program is running. it seems alot faster. i think start up and shut down was alot slower before.