PDA

View Full Version : Subscribe on user registration - How?



Hgluckman
09-16-2012, 01:06 AM
New User here.

One of the reasons I purchased WP Subscribers was to take advantage of the feature "Subscribe on user registration" I have not found any information as to how to activate that. I am using Aweber for my email service, and have successfully pasted in the opt-in code.

Where/how do I activate the Subscribe on user registration feature?

Thanks

Howard Gluckman

Admin
09-16-2012, 09:17 AM
hi Howard,

it's in the menu

Others Optin-forms

then you have 2 tabs on top, it's the second one ( Optin on registration )

here is a screenshoot

225

Hgluckman
09-16-2012, 02:15 PM
Thanks, I don't know why I couldn't find that previously. However, I have it checked now, and it doesn't seem to be working... Any methods for debugging this suggested?

Admin
09-16-2012, 06:04 PM
ah, that's another story, I will notify the dev team, I m not using this option myself, so I guess, I would need to test on my side too. just to be sure, what is your version of wordpress ? and do you have any pluging to handle comments or users ( facebook connect, gravatar etc... )

Hgluckman
09-16-2012, 11:15 PM
Wordpress is 3.4.2
I am using User Registration Aide 1.2.5 to register users.

Admin
09-17-2012, 07:15 AM
and what User Registration Aide is doing ? ( did you try without it ) ?

Cliff Davis
08-28-2013, 04:45 PM
I am having same problem. It is enabled but does not seem to be working. I am using user registration aide 1.2.8. any advice?

johncd
11-09-2013, 06:43 AM
Just to be clear, this makes anyone who register to your blog (aka, get added to the wordpress users list) also be subscribed to your autoresponder service like aweber, mailchimp, getresponse, arpreach etc?

If so, it doesn't seem to be working for me. I'm using arpreach and I tried registering a user via Admin>Users>Add New, and the new user didn't get added to my autoresponder's list.
Same with adding users thru the /wp-login.php?action=register page.

The form is working since I tested it with the optin in post form.

Jean-Christophe Bisoux
11-09-2013, 08:22 AM
Hi John,

did you enable auto subscribe on user registration ?

It's in Others Opt-in Forms > Opt-in on Registration

Regards,
JC

johncd
11-09-2013, 05:44 PM
Hi Jean,

Yes, I did tick that setting.

So I'm trying to to find out why its not auto subscribing. So I disabled other plugins.
I only have this plugin activated, and created a Post Optin form in wp subscribers.
I also set the settings in arpreach to single optin for the mean time to see if it makes any difference, but to no success.

Would you like to check it out? I can pm you the site details (its just a test site).

Jean-Christophe Bisoux
11-10-2013, 06:03 AM
Hi John,

I try with a Worpdres installation from scratch without other plugin and with the default theme, and it's working.

If you can send me the url, and if it's posible to have a temporary admin account.

regards,
JC

johncd
11-10-2013, 02:13 PM
Ok, that's weird.

I pm'ing you with the site details.

xtraday
03-16-2014, 08:29 PM
Just to be clear, this makes anyone who register to your blog (aka, get added to the wordpress users list) also be subscribed to your autoresponder service like aweber, mailchimp, getresponse, arpreach etc?

If so, it doesn't seem to be working for me. I'm using arpreach and I tried registering a user via Admin>Users>Add New, and the new user didn't get added to my autoresponder's list.
Same with adding users thru the /wp-login.php?action=register page.

The form is working since I tested it with the optin in post form.

I have exactly the same problem.

I'm using getresponse and my new members are not registered on the autoresponder's list. They are just subscribed in the campaign.

Enable auto subscribe on user registration is already enabled in "Other Opt-in Forms".

Thanks for your help.

Here is the solution : you have to set the initial message of the campaign in the Settings Tab of the web form creator. It works like a charm now !