Most of the support we received can be quickly and easily adressed, by following this checklist

- do you have activated the plugin ? after an update the plugin may not be installed correctly make sure it is activated in the plugin list of your wordpress web site.

- Do you have a cache plugin ?
Plugin such W3 Total Cache are known to cause some issue, a new version will adress this, but before, please check if WPSubscribers works with your cache unactivated

- Turn Off the preview mode ... some people forget they will see the popups and forms if they turn "Admin preview" , please check the status of this .

- If nothing appears, please check your rules and especially don't forget, it's normal to not see anything once you filled the email or close the dialog box, to check again, you need to clean the cookies. another great way to test is to use 1 browser ( chrome for example ) for development, and another browser ( firefox ) for testing.
Use the private / incognito mode, will force the test browser to not store or use the cookies, it's a fast way to test your popups.

- Jquery version of your wordpress themes. this one is a little bit more technical but found a few days ago. WPSubscribers uses JQuery but your theme can too. you need to check the current jquery version of your theme as it may needs to be updated. it is the case, we will do another thread to explain what to do and how to update it.

- If you have a problem after an update, just desinstall and reinstall the plugin, it works most of the time. be sure you have updated all the other plugins. Also , please be sure your web site works without WPSubscribers ( desactivate it ) , if it doesnt, it means there is ANOTHER problem also to fix.