Results 1 to 10 of 10

Thread: WP Subscribers kills my footer

  1. #1

    WP Subscribers kills my footer

    Hey there party people! :-)

    I have a somewhat strange problem:

    I am a big fan of wpsubscibers - and it works on most of my sites - but on my main site it prevents the footer from being loaded
    when I activate the plugin. Even when I deactivate every other plugin and switch to 2011 theme.

    For example:

    on http://marketingnow.de it works fine. (look into a single post)
    but on http://changenow.de (which uses the same theme - and stuff) it does not work.

    Updated the plugin - running WP 3.4 on all sites. Any ideas? I am really clueless ....

    Thanks and greetings,

    André

    (as it is killing my footer which means my analytics and aweber pop-up I deactived it on changenow.de - if you want to look into it, just let me know and I will activate it again.)

  2. #2
    Administrator Admin's Avatar
    Join Date
    Dec 2010
    Location
    Toulouse, France
    Posts
    527
    are you using facebook connect on your web site ?

    if you want we take a look we will need an admin access to your web site, please contact us by the web site form

    http://www.wpsubscribers.com/contact-us

  3. #3
    Thanks! :-)

    Just sent you a message! :-)

    Greetings,

    André

  4. #4
    Junior Member
    Join Date
    Jun 2012
    Posts
    9
    I am having a similar problem. The issue appears to be in the function wps_content_popup_footer().

    I noticed that there was a conflict between WP Subscribers and TrafficPlayer. When I activated WP Subscribers, my embedded videos no longer worked. I finally noticed that my footer was missing as well. It appears that when WP Subscribers is activated, the WordPress get_footer() function fails ugly; nothing even gets logged into the Apache error logs. It just... stops. Without the javascript code for traffic player being dropped into the footer, the flowplayer doesn't initialize properly and my embedded videos don't work.

    I edited template/core.php and commented out the two add_action calls for 'get_footer'. One adds wps_content_popup_footer, the other adds wps_facebook. I can uncomment the one for wps_facebook and my footer still loads. As soon as I uncomment the one for wps_content_popup_footer, boom! No footer.

    In my experience, when php code executing within apache dies in this fashion, without logging any error message to the apache logs, it's usually because there is a call to an undefined function in the code. However, it looks like wps_content_popup_footer() doesn't call a lot of functions. The only thing that looks like it might be causing an issue is calls to array_rand() without a count value.

    I'm still trying to debug this, but the code isn't well formatted and it's hard to navigate.

  5. #5
    Junior Member
    Join Date
    Jun 2012
    Posts
    9
    OK, I think I have it. I'm not sure if it will solve your problem, Andre, but it solved mine.

    Go into the WP Subscribers configuration in your WordPress dashboard. Click the entry for "Create Opt-In Forms". Then click the button for "Configure Display Location". You'll get a list of all the current pages on your site with columns of checkboxes for your Opt-in Form or "Don't Display Popup". Until you have forms set up that you want to display, you'll probably just want to set the checkboxes for "Don't Display Popup" for all your pages, then click one of the "Save Changes" buttons on the page.

    The issue is that wps_content_popup_footer() is trying to access information in an array which is stored in the wordpress database as an option. Until you submit this form, at least once, the array isn't properly initialized with data and the code that tries to access the information chokes and dies, which in turn kills get_footer(), the WordPress function that loads the footer of your page in pretty much any decent theme.

    As I said, it appears to have solved the problem of the disappearing footer for me. I don't know if it will for you, but it is worth a try.

    best,
    Jim

  6. #6
    WPS Team
    Join Date
    Feb 2012
    Location
    Canillo, Andorra
    Posts
    284
    Hi,
    I put also a tips here http://forum.obviousidea.com/threads...oter-disappear
    Some time when you activate the plugin all the variable are not create and when you create a popup it will be correct it.

    Regards,

  7. #7
    WOW! :-))

    Thanks so much Jim! That really did the trick!

    But it was not the "optin pop-up" which was already fully disabled, but the "footer-optin" which did it at my site.
    I simply deactivated the display (as I do not use it) - and there the footer comes back.

    I am so thankful - you just solved a major headache of mine! Forum support at it's best!

    Thanks a lot again and many many greetings from Germany! :-)

    André

  8. #8
    Junior Member
    Join Date
    Jun 2012
    Posts
    9
    Andre,

    I'm pleased it helped you out. In many ways, WP Subscribers is an excellent piece of software, but there is a bit of finish work that doesn't seem to be done. I understand that it was recently acquired from the original developer(s) by the current owner(s), so I can understand if they haven't gotten completely up to speed. My experience so far, however, is that they are working very hard to support it properly. I've received emails and chatted with support personnel on Sunday afternoons. That's impressive.

    Good luck with your online ventures!

    best,
    Jim

  9. #9
    Junior Member
    Join Date
    Oct 2012
    Posts
    1

    Lost my footer completely

    I installed WPSubscribers yesterday and got it working.... got the footer opt-in working.
    Today I noticed that I lost my footer completely. I have tried all suggestion that I could find on the forum and nothing.
    The only way to get it back is to either deactivate the plugin or turn visible to admin only on.

    When I turn on visible to admin, I get my footer back to non-admin users. Admin user still do not get the footer section.

    Also, if I turn off Facebook connect, traditional connect method, i get my footer back.

    Any help would be greatly appreciated.
    The site is www.miamitravelplanet.com

    thx
    Last edited by fmg008; 10-11-2012 at 05:52 AM.

  10. #10
    WPS Team
    Join Date
    Feb 2012
    Location
    Canillo, Andorra
    Posts
    284
    Hi,
    Is it posible to have a temporary admin account ? it wil be easier to see what's happend ?
    For security you can send me the information by this form : http://www.wpsubscribers.com/contact-us

    Regards,

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •